CVE-2025-11777 Cross-team channel membership access
Attackers can access user metadata and channel membership from other teams due to missing permission checks in the Add Channel Member API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-11777?
CVE-2025-11777 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11 fail to properly validate team membership permissions in the Add Channel Member API which allows users from one team to access user metadata and channel membership information from other teams via the API endpoint
Weakness: CWE-863
Which versions are affected by CVE-2025-11777?
20 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
14 more packages
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.12+incompatible, 10.11.4+incompatible |
github.com/mattermost/mattermost Go | All versions | None |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v5 Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server/v5 Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost-server/v6 Go | All versions | 5.3.2-0.20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251212204551-54f2e9b4afd5 |
github.com/mattermost/mattermost/v5 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-11777?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 5.3.2-0.20250905150616-ba86dfc5876b, 10.11.4, 10.5.12 or 10.5.12+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-11777 being exploited?
There is no known exploitation of CVE-2025-11777 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-mqcj-8c2g-h97q, GO-2025-4122.