CVE-2025-11794 Password hash and MFA secret returned in user email verification endpoint

Medium 4.9 Published Updated

System administrators can access sensitive password hashes and MFA secrets via an unsanitized user verification endpoint in Mattermost.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11794?

CVE-2025-11794 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 14 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to sanitize user data which allows system administrators to access password hashes and MFA secrets via the POST /api/v4/users/{user_id}/email/verify/member endpoint

Weakness: CWE-200

Which versions are affected by CVE-2025-11794?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.4
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.4
github.com/mattermost/mattermost-server GoFrom 10.12.010.12.1
github.com/mattermost/mattermost-server GoFrom 10.12.010.12.1
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.12
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.12
6 more packages
github.com/mattermost/mattermost-server GoFrom 10.5.0+incompatible10.5.12+incompatible, 10.11.4+incompatible, 10.12.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250929212932-a41db04d2746
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250929212932-a41db04d2746
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250929212932-a41db04d2746

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-11794?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.4, 10.12.1, 10.5.12 or 10.5.12+incompatible.

Is CVE-2025-11794 being exploited?

There is no known exploitation of CVE-2025-11794 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-mqp8-pgg5-7x7m, GO-2025-4130.

Is CVE-2025-11794 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free