# CVE-2025-11842: Shazwazza Smidge Bundle path traversal

> Attackers can exploit a path traversal vulnerability in the Smidge library's Bundle Handler to read arbitrary files.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-9rvm-p3qm-f4vv

## What is CVE-2025-11842?

CVE-2025-11842 is a medium-severity path traversal vulnerability in Shazwazza Smidge, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security vulnerability has been detected in Shazwazza Smidge up to 4.5.1. The impacted element is an unknown function of the component Bundle Handler. The manipulation of the argument Version leads to path traversal. Remote exploitation of the attack is possible. Upgrading to version 4.6.0 is sufficient to resolve this issue. It is recommended to upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-11842?

2 open source packages ship an affected version, including Smidge.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Smidge` | NuGet | All versions | 4.6.0 |
| `Smidge` | NuGet | All versions | 4.6.0 |

## How do I fix CVE-2025-11842?

Upgrade Smidge to 4.6.0 or later.

## Is CVE-2025-11842 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11842 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11842 and fix it if it is affected.

What it is: CVE-2025-11842 is a medium-severity path traversal vulnerability in Shazwazza Smidge, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11842 exists.

Affected packages and fixed versions:
- Smidge (NuGet): affected all versions; fixed in 4.6.0
- Smidge (NuGet): affected all versions; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11842/ (Markdown: https://insights.sbomify.com/CVE-2025-11842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11842
- OSV: https://osv.dev/vulnerability/CVE-2025-11842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11842/
Summaries are generated and may contain mistakes; the official description above is the record.
