# CVE-2025-11849: Mammoth is vulnerable to Directory Traversal

> An attacker can read arbitrary files or cause denial of service by crafting a malicious docx file with external image links processed by the Mammoth library.

- **Severity:** Medium 6.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** GHSA-rmjr-87wv-gf87, PYSEC-2026-1603

## What is CVE-2025-11849?

CVE-2025-11849 is a medium-severity path traversal vulnerability in Mammoth, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package mammoth from 0.3.25 and before 1.11.0; versions of the package mammoth from 0.3.25 and before 1.11.0; versions of the package mammoth before 1.11.0; versions of the package org.zwobble.mammoth:mammoth before 1.11.0 are vulnerable to Directory Traversal due to the lack of path or file type validation when processing a docx file containing an image with an external link (r:link attribute instead of embedded r:embed). The library resolves the URI to a file path and after reading, the content is encoded as base64 and included in the HTML output as a data URI. An attacker can read arbitrary files on the system where the conversion is performed or cause an excessive resources consumption by crafting a docx file that links to special device files such as /dev/random or /dev/zero.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-11849?

9 open source packages ship an affected version, including mammoth, org.zwobble.mammoth:mammoth and Mammoth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mammoth` | PyPI | From 0.3.25 | 1.11.0 |
| `mammoth` | PyPI | From 0.3.25 | 1.11.0 |
| `mammoth` | PyPI | From 0.3.25 | 1.11.0 |
| `mammoth` | npm | From 0.3.25 | 1.11.0 |
| `mammoth` | npm | From 0.3.25 | 1.11.0 |
| `org.zwobble.mammoth:mammoth` | Maven | All versions | 1.11.0 |
| `org.zwobble.mammoth:mammoth` | Maven | All versions | 1.11.0 |
| `Mammoth` | NuGet | All versions | 1.11.0 |
| `Mammoth` | NuGet | All versions | 1.11.0 |

## How do I fix CVE-2025-11849?

Upgrade mammoth to 1.11.0 or later.

## Is CVE-2025-11849 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11849 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11849 and fix it if it is affected.

What it is: CVE-2025-11849 is a medium-severity path traversal vulnerability in Mammoth, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11849 exists.

Affected packages and fixed versions:
- mammoth (PyPI): affected from 0.3.25; fixed in 1.11.0
- mammoth (PyPI): affected from 0.3.25; fixed in 1.11.0
- mammoth (PyPI): affected from 0.3.25; fixed in 1.11.0
- mammoth (npm): affected from 0.3.25; fixed in 1.11.0
- mammoth (npm): affected from 0.3.25; fixed in 1.11.0
- org.zwobble.mammoth:mammoth (Maven): affected all versions; fixed in 1.11.0
- org.zwobble.mammoth:mammoth (Maven): affected all versions; fixed in 1.11.0
- Mammoth (NuGet): affected all versions; fixed in 1.11.0
- Mammoth (NuGet): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11849/ (Markdown: https://insights.sbomify.com/CVE-2025-11849/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11849
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11849
- OSV: https://osv.dev/vulnerability/CVE-2025-11849

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11849/
Summaries are generated and may contain mistakes; the official description above is the record.
