CVE-2025-11865 Incorrect Authorization in GitLab
An attacker can remove Duo flows belonging to another user due to incorrect authorization checks in GitLab Enterprise Edition.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-11865?
CVE-2025-11865 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 15 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions from 18.1 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that, under certain circumstances, could have allowed an attacker to remove Duo flows of another user.
Weakness: CWE-863
Which versions are affected by CVE-2025-11865?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 18.1.0 | 18.3.6, 18.4.4, 18.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-11865?
Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-11865 being exploited?
There is no known exploitation of CVE-2025-11865 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-11865, GHSA-5vpg-xw87-4738, UBUNTU-CVE-2025-11865.