# CVE-2025-1194: Regular Expression Denial of Service (ReDoS) in huggingface/transformers

> Attackers can cause denial of service in applications using the transformers library by submitting inputs that trigger expensive regex backtracking.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-fpwr-67px-3qhx, PYSEC-2026-1984

## What is CVE-2025-1194?

CVE-2025-1194 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Regular Expression Denial of Service (ReDoS) vulnerability was identified in the huggingface/transformers library, specifically in the file `tokenization_gpt_neox_japanese.py` of the GPT-NeoX-Japanese model. The vulnerability occurs in the SubWordJapaneseTokenizer class, where regular expressions process specially crafted inputs. The issue stems from a regex exhibiting exponential complexity under certain conditions, leading to excessive backtracking. This can result in high CPU usage and potential application downtime, effectively creating a Denial of Service (DoS) scenario. The affected version is v4.48.1 (latest).

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-1194?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.50.0 |
| `transformers` | PyPI | All versions | 4.50.0 |
| `transformers` | PyPI | All versions | 4.50.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2025-1194?

Upgrade transformers to 4.50.0 or later.

## Is CVE-2025-1194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1194 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1194 and fix it if it is affected.

What it is: CVE-2025-1194 is a medium-severity denial of service vulnerability in huggingface/transformers, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1194 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.50.0
- transformers (PyPI): affected all versions; fixed in 4.50.0
- transformers (PyPI): affected all versions; fixed in 4.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1194/ (Markdown: https://insights.sbomify.com/CVE-2025-1194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1194
- OSV: https://osv.dev/vulnerability/CVE-2025-1194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1194/
Summaries are generated and may contain mistakes; the official description above is the record.
