CVE-2025-11971 Incorrect Authorization in GitLab
Authenticated attackers can trigger unauthorized pipeline executions by manipulating commits, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-11971?
CVE-2025-11971 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 27 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
GitLab has remediated an issue in GitLab EE affecting all versions from 10.6 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker to trigger unauthorized pipeline executions by manipulating commits.
Weakness: CWE-863
Which versions are affected by CVE-2025-11971?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 10.6.0 | 18.3.5, 18.4.3, 18.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-11971?
Upgrade gitlab to a fixed version for your release line: 18.3.5, 18.4.3 or 18.5.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-11971 being exploited?
There is no known exploitation of CVE-2025-11971 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-11971, GHSA-jgp3-92wq-g4pq, UBUNTU-CVE-2025-11971.