CVE-2025-11974 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An unauthenticated attacker can cause a denial of service by uploading large files to specific API endpoints in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11974?

CVE-2025-11974 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.7 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an unauthenticated attacker to create a denial of service condition by uploading large files to specific API endpoints.

Weakness: CWE-770

Which versions are affected by CVE-2025-11974?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.7.018.3.5, 18.4.3, 18.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-11974?

Upgrade gitlab to a fixed version for your release line: 18.3.5, 18.4.3 or 18.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-11974 being exploited?

There is no known exploitation of CVE-2025-11974 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11974, GHSA-rcvw-fc36-wjhj, UBUNTU-CVE-2025-11974.

Is CVE-2025-11974 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free