CVE-2025-11979 Use-after-free in the MongoDB server query planner may lead to crash or undefined behavior

Medium 5.3 Published Updated

An authorized user can crash the MongoDB server by triggering a use-after-free during concurrent DDL and query operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11979?

CVE-2025-11979 is a medium-severity use after free vulnerability in Mongodb Mongodb, published on 20 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authorized user may crash the MongoDB server by causing buffer over-read. This can be done by issuing a DDL operation while queries are being issued, under some conditions. This issue affects MongoDB Server v7.0 versions prior to 7.0.25, MongoDB Server v8.0 versions prior to 8.0.15, and MongoDB Server version 8.2.0.

Weakness: CWE-416

Which versions are affected by CVE-2025-11979?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 7.0.07.0.25, 8.0.15

Products include Mongodb Mongodb.

How do I fix CVE-2025-11979?

Upgrade mongodb to a fixed version for your release line: 7.0.25 or 8.0.15.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2025-11979 being exploited?

There is no known exploitation of CVE-2025-11979 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-11979, GHSA-ghg7-x6j9-jm6p, MINI-6628-wm79-cg93, MINI-gv94-7pf2-c3fx.

Is CVE-2025-11979 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free