# CVE-2025-11979: Use-after-free in the MongoDB server query planner may lead to crash or undefined behavior

> An authorized user can crash the MongoDB server by triggering a use-after-free during concurrent DDL and query operations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2025
- **Updated:** 20 Oct 2025
- **Also known as:** BIT-mongodb-2025-11979, GHSA-ghg7-x6j9-jm6p, MINI-6628-wm79-cg93, MINI-gv94-7pf2-c3fx

## What is CVE-2025-11979?

CVE-2025-11979 is a medium-severity use after free vulnerability in Mongodb Mongodb, published on 20 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authorized user may crash the MongoDB server by causing buffer over-read. This can be done by issuing a DDL operation while queries are being issued, under some conditions. This issue affects MongoDB Server v7.0 versions prior to 7.0.25, MongoDB Server v8.0 versions prior to 8.0.15, and MongoDB Server version 8.2.0.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2025-11979?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 7.0.0 | 7.0.25, 8.0.15 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-11979?

Upgrade mongodb to a fixed version for your release line: 7.0.25 or 8.0.15.

## Is CVE-2025-11979 being exploited?

There is no known exploitation of CVE-2025-11979 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11979 and fix it if it is affected.

What it is: CVE-2025-11979 is a medium-severity use after free vulnerability in Mongodb Mongodb, published on 20 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11979 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.25, 8.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11979/ (Markdown: https://insights.sbomify.com/CVE-2025-11979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11979
- OSV: https://osv.dev/vulnerability/CVE-2025-11979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11979/
Summaries are generated and may contain mistakes; the official description above is the record.
