CVE-2025-11984 Authentication Bypass Using an Alternate Path or Channel in GitLab

Medium 6.8 Published Updated

Authenticated users can bypass WebAuthn two-factor authentication by manipulating session state, requiring GitLab administrators to upgrade.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11984?

CVE-2025-11984 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.1 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to bypass WebAuthn two-factor authentication by manipulating the session state under certain conditions.

Weakness: CWE-288

Which versions are affected by CVE-2025-11984?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.1.018.4.6, 18.5.4, 18.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-11984?

Upgrade gitlab to a fixed version for your release line: 18.4.6, 18.5.4 or 18.6.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-11984 being exploited?

There is no known exploitation of CVE-2025-11984 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11984, GHSA-m766-xfqm-qm37, UBUNTU-CVE-2025-11984.

Is CVE-2025-11984 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free