CVE-2025-11989 Missing Authorization in GitLab

Low 3.7 Published Updated

Authenticated attackers can execute unauthorized quick actions via malicious commands in descriptions, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-11989?

CVE-2025-11989 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.6.0 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker to execute unauthorized quick actions by including malicious commands in specific descriptions.

Weakness: CWE-862

Which versions are affected by CVE-2025-11989?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.6.018.3.5, 18.4.3, 18.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-11989?

Upgrade gitlab to a fixed version for your release line: 18.3.5, 18.4.3 or 18.5.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-11989 being exploited?

There is no known exploitation of CVE-2025-11989 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11989, GHSA-5qhc-78h9-5m5x, UBUNTU-CVE-2025-11989.

Is CVE-2025-11989 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free