CVE-2025-12029 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.0 Published Updated

An unauthenticated attacker can inject malicious scripts into the Swagger UI to perform unauthorized actions on behalf of other users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-12029?

CVE-2025-12029 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.11 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have, under certain circumstances, allowed an unauthenticated user to perform unauthorized actions on behalf of another user by injecting malicious external scripts into the Swagger UI."

Weakness: CWE-79

Which versions are affected by CVE-2025-12029?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.018.4.6, 18.5.4, 18.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-12029?

Upgrade gitlab to a fixed version for your release line: 18.4.6, 18.5.4 or 18.6.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-12029 being exploited?

There is no known exploitation of CVE-2025-12029 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12029, GHSA-2jwx-73fx-pwrv.

Is CVE-2025-12029 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free