CVE-2025-12044 Vault Vulnerable to Denial of Service Due to Rate Limit Regression

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service in HashiCorp Vault by sending complex JSON payloads that bypass rate limits.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12044?

CVE-2025-12044 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON payloads. This occurs due to a regression from a previous fix for [+HCSEC-2025-24+|https://discuss.hashicorp.com/t/hcsec-2025-24-vault-denial-of-service-though-complex-json-payloads/76393]  which allowed for processing JSON payloads before applying rate limits. This vulnerability, CVE-2025-12044, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.16.27, 1.19.11, 1.20.5, and 1.21.0.

Weakness: CWE-770

Which versions are affected by CVE-2025-12044?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/vault GoFrom 1.20.31.21.0
github.com/hashicorp/vault GoFrom 1.20.31.21.0
github.com/hashicorp/vault GoFrom 1.20.31.21.0
vault BitnamiFrom 0.6.01.16.27, 1.19.11, 1.21.0

Products include Hashicorp Vault.

How do I fix CVE-2025-12044?

Upgrade github.com/hashicorp/vault to 1.21.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-12044 being exploited?

There is no known exploitation of CVE-2025-12044 in the wild and no public exploit code.

All Hashicorp Vault vulnerabilities

Sources

Also known as BIT-vault-2025-12044, GHSA-vp5w-xcfc-73wf, GO-2025-4071, MINI-g359-jf68-chwg.

Is CVE-2025-12044 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free