# CVE-2025-12044: Vault Vulnerable to Denial of Service Due to Rate Limit Regression

> Unauthenticated attackers can cause denial of service in HashiCorp Vault by sending complex JSON payloads that bypass rate limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** BIT-vault-2025-12044, GHSA-vp5w-xcfc-73wf, GO-2025-4071, MINI-g359-jf68-chwg

## What is CVE-2025-12044?

CVE-2025-12044 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON payloads. This occurs due to a regression from a previous fix for [+HCSEC-2025-24+|https://discuss.hashicorp.com/t/hcsec-2025-24-vault-denial-of-service-though-complex-json-payloads/76393]  which allowed for processing JSON payloads before applying rate limits. This vulnerability, CVE-2025-12044, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.16.27, 1.19.11, 1.20.5, and 1.21.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-12044?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.20.3 | 1.21.0 |
| `github.com/hashicorp/vault` | Go | From 1.20.3 | 1.21.0 |
| `github.com/hashicorp/vault` | Go | From 1.20.3 | 1.21.0 |
| `vault` | Bitnami | From 0.6.0 | 1.16.27, 1.19.11, 1.21.0 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-12044?

Upgrade github.com/hashicorp/vault to 1.21.0 or later.

## Is CVE-2025-12044 being exploited?

There is no known exploitation of CVE-2025-12044 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12044 and fix it if it is affected.

What it is: CVE-2025-12044 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12044 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.20.3; fixed in 1.21.0
- github.com/hashicorp/vault (Go): affected from 1.20.3; fixed in 1.21.0
- github.com/hashicorp/vault (Go): affected from 1.20.3; fixed in 1.21.0
- vault (Bitnami): affected from 0.6.0; fixed in 1.16.27, 1.19.11, 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12044/ (Markdown: https://insights.sbomify.com/CVE-2025-12044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12044
- OSV: https://osv.dev/vulnerability/CVE-2025-12044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12044/
Summaries are generated and may contain mistakes; the official description above is the record.
