CVE-2025-12073 Server-Side Request Forgery (SSRF) in GitLab

Medium 4.3 Published Updated

Authenticated users can bypass protections in Git repository imports to perform server-side request forgery against internal services.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12073?

CVE-2025-12073 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 11 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.0 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions, could have allowed an authenticated user to perform server-side request forgery against internal services by bypassing protections in the Git repository import functionality.

Weakness: CWE-918

Which versions are affected by CVE-2025-12073?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.0.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2025-12073?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-12073 being exploited?

There is no known exploitation of CVE-2025-12073 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12073, GHSA-hfx3-365h-vfrv, UBUNTU-CVE-2025-12073.

Is CVE-2025-12073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free