# CVE-2025-12082: CivicTheme Design System - Moderately critical - Information disclosure - SA-CONTRIB-2025-112

> An attacker can access restricted information in the CivicTheme Design System due to incorrect authorization checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-112, GHSA-qxr9-f877-9842

## What is CVE-2025-12082?

CVE-2025-12082 is a high-severity missing authorization vulnerability in Drupal CivicTheme Design System, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Drupal CivicTheme Design System allows Forceful Browsing.This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-12082?

2 open source packages ship an affected version, including drupal/civictheme. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/civictheme` | Packagist | All versions | 1.12.0 |
| `drupal/civictheme` | Packagist | All versions | 1.12.0 |
| `drupal/civictheme` | Packagist:https://packages.drupal.org/8 | All versions | 1.12.0 |

Products: Salsa.digital Civictheme Design System.

## How do I fix CVE-2025-12082?

Upgrade drupal/civictheme to 1.12.0 or later.

## Is CVE-2025-12082 being exploited?

There is no known exploitation of CVE-2025-12082 in the wild and no public exploit code.

## Other vulnerabilities in Drupal CivicTheme Design System

- [CVE-2025-12083](https://insights.sbomify.com/CVE-2025-12083/): CivicTheme Design System - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-113 (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12082 and fix it if it is affected.

What it is: CVE-2025-12082 is a high-severity missing authorization vulnerability in Drupal CivicTheme Design System, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12082 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/civictheme (Packagist): affected all versions; fixed in 1.12.0
- drupal/civictheme (Packagist): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12082/ (Markdown: https://insights.sbomify.com/CVE-2025-12082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12082
- OSV: https://osv.dev/vulnerability/CVE-2025-12082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12082/
Summaries are generated and may contain mistakes; the official description above is the record.
