{"answers":{"affected":"2 open source packages ship an affected version, including drupal/civictheme. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12083 in the wild and no public exploit code.","fix":"Upgrade drupal/civictheme to 1.12.0 or later.","what":"CVE-2025-12083 is a medium-severity cross-site scripting vulnerability in Drupal CivicTheme Design System, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-12083 and fix it if it is affected.\n\nWhat it is: CVE-2025-12083 is a medium-severity cross-site scripting vulnerability in Drupal CivicTheme Design System, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-12083 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/civictheme (Packagist): affected all versions; fixed in 1.12.0\n- drupal/civictheme (Packagist): affected all versions; fixed in 1.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12083/ (Markdown: https://insights.sbomify.com/CVE-2025-12083/index.md)","id":"CVE-2025-12083","markdown":"https://insights.sbomify.com/CVE-2025-12083/index.md","name":"CVE-2025-12083","record":{"aliases":["DRUPAL-CONTRIB-2025-113","GHSA-h72q-cq3w-h3wc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal design system","requires_auth":"none","summary":"An attacker can inject malicious scripts into web pages viewed by other users via the CivicTheme Design System module.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"civictheme_design_system","vendor":"salsa.digital"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CivicTheme Design System allows Cross-Site Scripting (XSS).This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CivicTheme Design System - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-113","id":"CVE-2025-12083","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Quadratic complexity in node ID cache clearing","id":"CVE-2025-12084"},"packages":[{"ecosystem":"Packagist","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"drupal/civictheme","purl":null,"source":"GHSA-h72q-cq3w-h3wc"},{"ecosystem":"Packagist","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"drupal/civictheme","purl":"pkg:composer/drupal/civictheme","source":"GHSA-h72q-cq3w-h3wc"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"drupal/civictheme","purl":"pkg:composer/drupal/civictheme?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-113"}],"prev":{"headline":"CivicTheme Design System - Moderately critical - Information disclosure - SA-CONTRIB-2025-112","id":"CVE-2025-12082"},"products":["CivicTheme Design System"],"published":"2025-10-29","related":[{"cvss_score":7.5,"headline":"CivicTheme Design System - Moderately critical - Information disclosure - SA-CONTRIB-2025-112","id":"CVE-2025-12082","kev_date_added":null,"published":"2025-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages viewed by other users via the CivicTheme Design System module.","url":"https://insights.sbomify.com/CVE-2025-12083/"}