# CVE-2025-1211: Server-side Request Forgery (SSRF) in hackney

> Hackney library allows SSRF via URL parsing discrepancies, enabling attackers to bypass host checks and access internal resources.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2025
- **Updated:** 16 Mar 2025
- **Also known as:** GHSA-vq52-99r9-h5pw

## What is CVE-2025-1211?

CVE-2025-1211 is a medium-severity server-side request forgery vulnerability in hackney, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package hackney before 1.21.0 are vulnerable to Server-side Request Forgery (SSRF) due to improper parsing of URLs by URI built-in module and hackey. Given the URL http://127.0.0.1?@127.2.2.2/, the URI function will parse and see the host as 127.0.0.1 (which is correct), and hackney will refer the host as 127.2.2.2/. This vulnerability can be exploited when users rely on the URL function for host checking.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-1211?

2 open source packages ship an affected version, including hackney.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | All versions | 1.21.0 |
| `hackney` | Hex | All versions | 1.21.0 |

## How do I fix CVE-2025-1211?

Upgrade hackney to 1.21.0 or later.

## Is CVE-2025-1211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1211 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1211 and fix it if it is affected.

What it is: CVE-2025-1211 is a medium-severity server-side request forgery vulnerability in hackney, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1211 exists.

Affected packages and fixed versions:
- hackney (Hex): affected all versions; fixed in 1.21.0
- hackney (Hex): affected all versions; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1211/ (Markdown: https://insights.sbomify.com/CVE-2025-1211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1211
- OSV: https://osv.dev/vulnerability/CVE-2025-1211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1211/
Summaries are generated and may contain mistakes; the official description above is the record.
