# CVE-2025-12110: Keycloak does not invalidate offline sessions when the offline_access scope is removed

> Attackers can maintain access via offline sessions even after administrators remove the offline_access scope from a client configuration.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 20 Jan 2026
- **Also known as:** ECHO-6fb2-4b82-1991, GHSA-895x-rfqp-jh5c, MINI-9c7w-jxp3-vj6g

## What is CVE-2025-12110?

CVE-2025-12110 is a medium-severity vulnerability in Red Hat build of Keycloak 26.2, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. An offline session continues to be valid when the offline_access scope is removed from the client. The refresh token is accepted and you can continue to request new tokens for the session. As it can lead to a situation where an administrator removes the scope, and assumes that offline sessions are no longer available, but they are.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-12110?

2 open source packages ship an affected version, including org.keycloak:keycloak-services.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.2.3 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.2.3 |

## How do I fix CVE-2025-12110?

Upgrade org.keycloak:keycloak-services to 26.2.3 or later.

## Is CVE-2025-12110 being exploited?

There is no known exploitation of CVE-2025-12110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12110 and fix it if it is affected.

What it is: CVE-2025-12110 is a medium-severity vulnerability in Red Hat build of Keycloak 26.2, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.2.3
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12110/ (Markdown: https://insights.sbomify.com/CVE-2025-12110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12110
- OSV: https://osv.dev/vulnerability/CVE-2025-12110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12110/
Summaries are generated and may contain mistakes; the official description above is the record.
