# CVE-2025-12119: Bulk write with options may read invalid memory

> An attacker can cause a denial of service by passing large options to bulk write operations in the MongoDB C Driver.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 14 Jan 2026
- **Also known as:** DEBIAN-CVE-2025-12119, DLA-4438-1, GHSA-mwcc-7vpp-xmv9, JLSEC-2026-181, OESA-2025-2821, OESA-2025-2822, OESA-2025-2823, OESA-2025-2824, OESA-2025-2890, UBUNTU-CVE-2025-12119

## What is CVE-2025-12119?

CVE-2025-12119 is a medium-severity memory corruption vulnerability in MongoDB C Driver, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A mongoc_bulk_operation_t may read invalid memory if large options are passed.

Weakness: CWE-825 (Expired Pointer Dereference)

## Which versions are affected by CVE-2025-12119?

2 open source packages ship an affected version, including mongodb/mongodb-extension. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb/mongodb-extension` | Packagist | All versions | 1.21.2 |
| `mongodb/mongodb-extension` | Packagist | All versions | 1.21.2 |

Products: Mongodb C Driver, Mongodb Php Driver.

## How do I fix CVE-2025-12119?

Upgrade mongodb/mongodb-extension to 1.21.2 or later.

## Is CVE-2025-12119 being exploited?

There is no known exploitation of CVE-2025-12119 in the wild and no public exploit code.

## Other vulnerabilities in MongoDB C Driver

- [CVE-2026-93393](https://insights.sbomify.com/CVE-2026-93393/): Heap overflow via oversized decrypted TLS record sequence in Windows Secure Channel stream (critical 9.2)
- [CVE-2026-6691](https://insights.sbomify.com/CVE-2026-6691/): MongoDB C Driver Cyrus SASL Canonicalization Buffer Overflow (high 8.6)
- [CVE-2026-84964](https://insights.sbomify.com/CVE-2026-84964/): Heap corruption via OCSP request double free from crafted multi-URL certificate in TLS client (high 8.2)
- [CVE-2024-7553](https://insights.sbomify.com/CVE-2024-7553/): Accessing Untrusted Directory May Allow Local Privilege Escalation (high 7.3)
- [CVE-2026-93395](https://insights.sbomify.com/CVE-2026-93395/): Integer Underflow → Heap Out-of-Bounds Read in `bson_new_from_buffer() (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12119 and fix it if it is affected.

What it is: CVE-2025-12119 is a medium-severity memory corruption vulnerability in MongoDB C Driver, published on 18 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12119 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb/mongodb-extension (Packagist): affected all versions; fixed in 1.21.2
- mongodb/mongodb-extension (Packagist): affected all versions; fixed in 1.21.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12119/ (Markdown: https://insights.sbomify.com/CVE-2025-12119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12119
- OSV: https://osv.dev/vulnerability/CVE-2025-12119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12119/
Summaries are generated and may contain mistakes; the official description above is the record.
