# CVE-2025-12141: Grafana Alerting Editors can edit destination of webhooks they did not create

> Editors can modify webhook destinations and extract redacted credentials, leading to unauthorized access to external integrations.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:U/S:N/AU:Y`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** BIT-grafana-2025-12141, GHSA-pcxf-fmpx-32ph, MINI-5x9m-rf84-3qw6, MINI-68w4-2w9v-hx5r, MINI-79pf-w8vp-mrq8, MINI-cxr7-5r75-wvc6, MINI-hw32-cfr9-c475, MINI-j238-v89v-f5qv, MINI-jqwj-wv42-g2qp, MINI-pvhf-8cj3-f7p5, MINI-qxwh-5x5x-7mvr, MINI-v554-c8wj-gmc9, MINI-wp3c-hp38-hh6x, MINI-wvmc-xrjg-3jvg, MINI-x3xh-p75f-mjx5, MINI-x8gf-5ch9-v7pm, UBUNTU-CVE-2025-12141, openSUSE-SU-2026:11108-1

## What is CVE-2025-12141?

CVE-2025-12141 is a low-severity missing authorization vulnerability in Grafana Grafana, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Grafana's alerting system, users with edit permissions for a contact point, specifically the permissions “alert.notifications:write” or “alert.notifications.receivers:test” that are granted as part of the fixed role "Contact Point Writer", which is part of the basic role Editor - can edit contact points created by other users, modify the endpoint URL to a controlled server. By invoking the test functionality, attackers can capture and extract redacted secure settings, such as authentication credentials for third-party services (e.g., Slack tokens). This leads to unauthorized access and potential compromise of external integrations.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-12141?

1 open source package ship an affected version, including grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana` | Bitnami | From 8.0.0 | 12.3.1 |
| `grafana` | openSUSE:Tumbleweed | All versions | 12.4.4-1.1 |

Products: Grafana Grafana.

## How do I fix CVE-2025-12141?

Upgrade grafana to 12.3.1 or later.

## Is CVE-2025-12141 being exploited?

There is no known exploitation of CVE-2025-12141 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12141 and fix it if it is affected.

What it is: CVE-2025-12141 is a low-severity missing authorization vulnerability in Grafana Grafana, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12141 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana (Bitnami): affected from 8.0.0; fixed in 12.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12141/ (Markdown: https://insights.sbomify.com/CVE-2025-12141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12141
- OSV: https://osv.dev/vulnerability/CVE-2025-12141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12141/
Summaries are generated and may contain mistakes; the official description above is the record.
