CVE-2025-1215 vim main.c memory corruption

Low 2.4 Published Updated

Local attackers can exploit memory corruption in Vim via the --log argument to potentially execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-1215?

CVE-2025-1215 is a low-severity memory corruption vulnerability in Netapp Bootstrap Os, published on 12 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.

Weakness: CWE-119

Which versions are affected by CVE-2025-1215?

It affects 2 products.

Products include Netapp Bootstrap Os, Vim Vim.

How do I fix CVE-2025-1215?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-1215 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1215 exists.

All Netapp Bootstrap Os vulnerabilities

Sources

Also known as AZL-56708, AZL-56770, BELL-CVE-2025-1215, DEBIAN-CVE-2025-1215, ECHO-dbe6-d80f-0b2e, GHSA-6wvf-533r-84vc and 1 more.

Is CVE-2025-1215 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free