{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1215 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-1215 is a low-severity memory corruption vulnerability in Netapp Bootstrap Os, published on 12 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-1215 and fix it if it is affected.\n\nWhat it is: CVE-2025-1215 is a low-severity memory corruption vulnerability in Netapp Bootstrap Os, published on 12 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1215 exists.\n\nAffected product: Netapp Bootstrap Os. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1215/ (Markdown: https://insights.sbomify.com/CVE-2025-1215/index.md)","id":"CVE-2025-1215","markdown":"https://insights.sbomify.com/CVE-2025-1215/index.md","name":"CVE-2025-1215","record":{"aliases":["AZL-56708","AZL-56770","BELL-CVE-2025-1215","DEBIAN-CVE-2025-1215","ECHO-dbe6-d80f-0b2e","GHSA-6wvf-533r-84vc","UBUNTU-CVE-2025-1215"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Vim text editor","requires_auth":"low_privilege","summary":"Local attackers can exploit memory corruption in Vim via the --log argument to potentially execute code or cause denial of service.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"bootstrap_os","vendor":"netapp"},{"product":"vim","vendor":"vim"}],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vim main.c memory corruption","id":"CVE-2025-1215","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"netapp:bootstrap_os","products":["netapp:bootstrap_os","vim:vim"],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":6,"next":{"headline":"ywoa OaNoticeMapper.xml selectNoticeList sql injection","id":"CVE-2025-1216"},"packages":[],"prev":{"headline":"pihome-shc PiHome Role-Based Access Control user_accounts.php authorization","id":"CVE-2025-1214"},"products":["vim"],"published":"2025-02-12","related":[{"cvss_score":5.9,"headline":"REXML denial of service vulnerability","id":"CVE-2024-43398","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.8,"headline":"Security feature bypass in Oracle Java SE","id":"CVE-2025-30691","kev_date_added":null,"published":"2025-04-15"},{"cvss_score":4.5,"headline":"heap-buffer-overflow in do_search() in Vim \u003c 9.1.0689","id":"CVE-2024-43790","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.4,"headline":"Vim vulnerable to potential data loss with zip.vim and special crafted zip files","id":"CVE-2025-29768","kev_date_added":null,"published":"2025-03-13"},{"cvss_score":4.3,"headline":"Denial of service in REXML","id":"CVE-2024-39908","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":3.9,"headline":"use-after-free when closing buffers in Vim","id":"CVE-2024-47814","kev_date_added":null,"published":"2024-10-07"},{"cvss_score":3.7,"headline":"Other in GraalVM","id":"CVE-2024-21211","kev_date_added":null,"published":"2024-10-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["n/a"]},"summary":"Local attackers can exploit memory corruption in Vim via the --log argument to potentially execute code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2025-1215/"}