# CVE-2025-1215: vim main.c memory corruption

> Local attackers can exploit memory corruption in Vim via the --log argument to potentially execute code or cause denial of service.

- **Severity:** Low 2.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2025
- **Updated:** 21 Mar 2025
- **Also known as:** AZL-56708, AZL-56770, BELL-CVE-2025-1215, DEBIAN-CVE-2025-1215, ECHO-dbe6-d80f-0b2e, GHSA-6wvf-533r-84vc, UBUNTU-CVE-2025-1215

## What is CVE-2025-1215?

CVE-2025-1215 is a low-severity memory corruption vulnerability in Netapp Bootstrap Os, published on 12 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-1215?

It affects 2 products.


Products: Netapp Bootstrap Os, Vim Vim.

## How do I fix CVE-2025-1215?

Upgrade to a fixed version.

## Is CVE-2025-1215 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1215 exists.

## Other vulnerabilities in Netapp Bootstrap Os

- [CVE-2024-43398](https://insights.sbomify.com/CVE-2024-43398/): REXML denial of service vulnerability (medium 5.9)
- [CVE-2025-30691](https://insights.sbomify.com/CVE-2025-30691/): Security feature bypass in Oracle Java SE (medium 4.8)
- [CVE-2024-43790](https://insights.sbomify.com/CVE-2024-43790/): heap-buffer-overflow in do_search() in Vim < 9.1.0689 (medium 4.5)
- [CVE-2025-29768](https://insights.sbomify.com/CVE-2025-29768/): Vim vulnerable to potential data loss with zip.vim and special crafted zip files (medium 4.4)
- [CVE-2024-39908](https://insights.sbomify.com/CVE-2024-39908/): Denial of service in REXML (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1215 and fix it if it is affected.

What it is: CVE-2025-1215 is a low-severity memory corruption vulnerability in Netapp Bootstrap Os, published on 12 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1215 exists.

Affected product: Netapp Bootstrap Os. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1215/ (Markdown: https://insights.sbomify.com/CVE-2025-1215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1215
- OSV: https://osv.dev/vulnerability/CVE-2025-1215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1215/
Summaries are generated and may contain mistakes; the official description above is the record.
