# CVE-2025-12150: Org.keycloak/keycloak-services: webauthn attestation statement verification bypass

> Attackers can bypass WebAuthn attestation policies to register forged authenticators, weakening authentication integrity in Keycloak deployments requiring direct attestation.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-keycloak-2025-12150, ECHO-c92c-0613-1aed, GHSA-7g5x-9c4v-4w5r, MINI-gh49-7c8h-vcmc, MINI-q54v-m94x-cg3p

## What is CVE-2025-12150?

CVE-2025-12150 is a low-severity vulnerability in Redhat Build of Keycloak, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Keycloak’s WebAuthn registration component. This vulnerability allows an attacker to bypass the configured attestation policy and register untrusted or forged authenticators via submission of an attestation object with fmt: "none", even when the realm is configured to require direct attestation. This can lead to weakened authentication integrity and unauthorized authenticator registration.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-12150?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.4.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.4.4 |
| `keycloak` | Bitnami | All versions | 26.4.4 |

Products: Redhat Build of Keycloak, Redhat Keycloak.

## How do I fix CVE-2025-12150?

Upgrade org.keycloak:keycloak-services to 26.4.4 or later.

## Is CVE-2025-12150 being exploited?

There is no known exploitation of CVE-2025-12150 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12150 and fix it if it is affected.

What it is: CVE-2025-12150 is a low-severity vulnerability in Redhat Build of Keycloak, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-12150 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.4.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.4.4
- keycloak (Bitnami): affected all versions; fixed in 26.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12150/ (Markdown: https://insights.sbomify.com/CVE-2025-12150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12150
- OSV: https://osv.dev/vulnerability/CVE-2025-12150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12150/
Summaries are generated and may contain mistakes; the official description above is the record.
