{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1217 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.32, 8.2.28, 8.3.19 or 8.4.5.","what":"CVE-2025-1217 is a medium-severity vulnerability in Php Php, published on 29 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1217 and fix it if it is affected.\n\nWhat it is: CVE-2025-1217 is a medium-severity vulnerability in Php Php, published on 29 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1217 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n- php (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n- php-min (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1217/ (Markdown: https://insights.sbomify.com/CVE-2025-1217/index.md)","id":"CVE-2025-1217","markdown":"https://insights.sbomify.com/CVE-2025-1217/index.md","name":"CVE-2025-1217","record":{"aliases":["AZL-59291","AZL-59294","BELL-CVE-2025-1217","BIT-libphp-2025-1217","BIT-php-2025-1217","BIT-php-min-2025-1217","DEBIAN-CVE-2025-1217","ECHO-00c2-fbc8-42d6","GHSA-v8xr-gpvj-cx9g","MINI-3vx7-wpcq-hqcm","MINI-6rhx-5g6r-pm4c","MINI-j2q9-wj76-m2p7","MINI-p39m-87r6-jfpf","UBUNTU-CVE-2025-1217"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP stream wrapper","requires_auth":"none","summary":"Attackers can exploit incorrect parsing of folded HTTP headers in PHP's stream wrapper to misinterpret responses, potentially bypassing security checks or accessing incorrect data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/AU:Y/R:A","version":"4.0"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP from 8.1.* before 8.1.32, from 8.2.* before 8.2.28, from 8.3.* before 8.3.19, from 8.4.* before 8.4.5, when http request module parses HTTP response obtained from a server, folded headers are parsed incorrectly, which may lead to misinterpreting the response and using incorrect headers, MIME types, etc.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Header parser of http stream wrapper does not handle folded headers","id":"CVE-2025-1217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"other","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Various packet overreads in mysqlnd_writeprotocol.c","id":"CVE-2025-1218"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2025-1217"},{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2025-1217"},{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2025-1217"}],"prev":{"headline":"ywoa OaNoticeMapper.xml selectNoticeList sql injection","id":"CVE-2025-1216"},"products":["PHP"],"published":"2025-03-29","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"Attackers can exploit incorrect parsing of folded HTTP headers in PHP's stream wrapper to misinterpret responses, potentially bypassing security checks or accessing incorrect data.","url":"https://insights.sbomify.com/CVE-2025-1217/"}