{"answers":{"affected":"8 open source packages ship an affected version, including at.yawk.lz4:lz4-java, net.jpountz.lz4:lz4 and org.lz4:lz4-java.","exploited":"There is no known exploitation of CVE-2025-12183 in the wild and no public exploit code.","fix":"Upgrade at.yawk.lz4:lz4-java to 1.8.1 or later.","what":"CVE-2025-12183 is a high-severity memory corruption vulnerability in at.yawk.lz4:lz4-java, published on 28 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12183 and fix it if it is affected.\n\nWhat it is: CVE-2025-12183 is a high-severity memory corruption vulnerability in at.yawk.lz4:lz4-java, published on 28 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12183 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.8.1\n- at.yawk.lz4:lz4-java (Maven): affected all versions; fixed in 1.8.1\n- net.jpountz.lz4:lz4 (Maven): affected all versions up to 1.3.0; no fix listed\n- net.jpountz.lz4:lz4 (Maven): affected all versions up to 1.3.0; no fix listed\n- org.lz4:lz4-java (Maven): affected all versions; fixed in 1.8.1\n- org.lz4:lz4-java (Maven): affected all versions; fixed in 1.8.1\n- org.lz4:lz4-pure-java (Maven): affected all versions up to 1.8.0; no fix listed\n- org.lz4:lz4-pure-java (Maven): affected all versions up to 1.8.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12183/ (Markdown: https://insights.sbomify.com/CVE-2025-12183/index.md)","id":"CVE-2025-12183","markdown":"https://insights.sbomify.com/CVE-2025-12183/index.md","name":"CVE-2025-12183","record":{"aliases":["CLEANSTART-2026-GE42999","CLEANSTART-2026-KF94035","CLEANSTART-2026-PT41131","CLEANSTART-2026-QA75834","CLEANSTART-2026-SD29232","CLEANSTART-2026-TF05670","CLEANSTART-2026-UW43752","DEBIAN-CVE-2025-12183","ECHO-cd33-ec70-d5f2","GHSA-vqf4-7m7x-wgfc","MINI-225v-h7g5-q6gp","MINI-24v6-26wh-p8v4","MINI-2vhh-cm6r-xcgj","MINI-48r7-m853-wqcm","MINI-495g-8688-hxjp","MINI-4xf2-3qcj-jc8w","MINI-57cj-hp52-m847","MINI-5fjx-pf4c-2qq7","MINI-5hwv-h9jj-rcf5","MINI-687c-hhpv-3453","MINI-73m6-w6qw-h8xc","MINI-7h6f-h5f7-qmgh","MINI-7x8q-mm54-xrg8","MINI-8jxp-f63f-4r35","MINI-977h-q487-5vjw","MINI-9jp7-7pcc-rqhf","MINI-c35j-3rq6-7jhc","MINI-c7rf-5hpw-2whv","MINI-cm7m-wq72-h427","MINI-cw8p-9p3q-mxqw","MINI-f8c3-r5h9-w89j","MINI-fmqj-v36r-6crq","MINI-fvvc-c98v-549j","MINI-g3c3-28rq-57gp","MINI-gq7r-322c-4xh9","MINI-h53g-8fq2-mvqv","MINI-hv8f-h7xm-h32q","MINI-j59w-x863-p9c8","MINI-j82v-c5j3-2c5m","MINI-jgpx-w54r-m47q","MINI-m4jf-8wg4-w623","MINI-mcq6-f95g-h57v","MINI-mgj6-3pjx-h6r8","MINI-mhqg-g944-6rvf","MINI-p4c4-4h4q-653p","MINI-pm2w-p68h-q4jm","MINI-pq6h-v3j7-w42h","MINI-pr2x-h6f3-hx7x","MINI-pvcx-8qfx-xqfm","MINI-qvcm-92f4-xg54","MINI-r39q-xp5h-3r37","MINI-r4q4-rq73-mcq4","MINI-v487-p4xx-j3gf","MINI-vf6x-9qjg-mrw6","MINI-vmxq-c9rp-p22f","MINI-w42f-3w2r-838h","MINI-w7j6-7cjf-f7cw","MINI-wqww-6jgv-v8ch","MINI-wr5w-ph98-323m","ROOT-APP-MAVEN-CVE-2025-12183","UBUNTU-CVE-2025-12183","openSUSE-SU-2026:10317-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java LZ4 compression library","requires_auth":"none","summary":"Remote attackers can cause denial of service and read adjacent memory in the lz4-java library via untrusted compressed input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Sonatype","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Out-of-bounds memory operations in org.lz4:lz4-java 1.8.0 and earlier allow remote attackers to cause denial of service and read adjacent memory via untrusted compressed input.","ecosystems":["Maven","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"org.lz4:lz4-java - Out-of-Bounds Memory Access","id":"CVE-2025-12183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":9,"n_references":2,"next":{"headline":"MeetingList \u003c= 0.11 - Authenticated (Admin+) Stored Cross-Site Scripting","id":"CVE-2025-12184"},"packages":[{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"at.yawk.lz4:lz4-java","purl":null,"source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"at.yawk.lz4:lz4-java","purl":"pkg:maven/at.yawk.lz4/lz4-java","source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.3.0"],"package":"net.jpountz.lz4:lz4","purl":null,"source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.3.0"],"package":"net.jpountz.lz4:lz4","purl":"pkg:maven/net.jpountz.lz4/lz4","source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"org.lz4:lz4-java","purl":null,"source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"org.lz4:lz4-java","purl":"pkg:maven/org.lz4/lz4-java","source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.8.0"],"package":"org.lz4:lz4-pure-java","purl":null,"source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["1.8.0"],"package":"org.lz4:lz4-pure-java","purl":"pkg:maven/org.lz4/lz4-pure-java","source":"GHSA-vqf4-7m7x-wgfc"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.109.1-1.1"],"introduced":["0"],"last_affected":[],"package":"grype","purl":"pkg:rpm/opensuse/grype\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10317-1"}],"prev":{"headline":"Qi Blocks \u003c= 1.4.3 - Missing Authorization to Arbitrary Attachment Resize","id":"CVE-2025-12182"},"products":[],"published":"2025-11-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-29","vendors":[]},"summary":"Remote attackers can cause denial of service and read adjacent memory in the lz4-java library via untrusted compressed input.","url":"https://insights.sbomify.com/CVE-2025-12183/"}