CVE-2025-1220 Null byte termination in hostnames
Attackers can bypass hostname validation checks in PHP applications by using null bytes, potentially leading to Server-Side Request Forgery.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-1220?
CVE-2025-1220 is a low-severity server-side request forgery vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* before 8.4.10 some functions like fsockopen() lack validation that the hostname supplied does not contain null characters. This may lead to other functions like parse_url() treat the hostname in different way, thus opening way to security problems if the user code implements access checks before access using such functions.
Weakness: CWE-918
Which versions are affected by CVE-2025-1220?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
php Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
php-min Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
Products include Php Php.
How do I fix CVE-2025-1220?
Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-1220 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1220 exists.
Other vulnerabilities in Php Php
Sources
Also known as AZL-65115, AZL-65250, BELL-CVE-2025-1220, BIT-libphp-2025-1220, BIT-php-2025-1220, BIT-php-min-2025-1220 and 13 more.