# CVE-2025-1220: Null byte termination in hostnames

> Attackers can bypass hostname validation checks in PHP applications by using null bytes, potentially leading to Server-Side Request Forgery.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-65115, AZL-65250, BELL-CVE-2025-1220, BIT-libphp-2025-1220, BIT-php-2025-1220, BIT-php-min-2025-1220, CLSA-2025-1753729863, CLSA-2025-1753768680, CLSA-2025-1753769145, CLSA-2025-1753780501, CLSA-2025-1753780622, DEBIAN-CVE-2025-1220, ECHO-56de-debe-74c4, GHSA-3cr5-j632-f35r, MINI-jx7f-qh42-w677, MINI-m7m2-w8h9-x632, MINI-r4jj-xcc4-ppvm, MINI-xvj9-mcp7-fv4p, UBUNTU-CVE-2025-1220

## What is CVE-2025-1220?

CVE-2025-1220 is a low-severity server-side request forgery vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* before 8.4.10 some functions like fsockopen() lack validation that the hostname supplied does not contain null characters. This may lead to other functions like parse_url() treat the hostname in different way, thus opening way to security problems if the user code implements access checks before access using such functions.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-1220?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php-min` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |

Products: Php Php.

## How do I fix CVE-2025-1220?

Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.

## Is CVE-2025-1220 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1220 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1220 and fix it if it is affected.

What it is: CVE-2025-1220 is a low-severity server-side request forgery vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1220 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php-min (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1220/ (Markdown: https://insights.sbomify.com/CVE-2025-1220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1220
- OSV: https://osv.dev/vulnerability/CVE-2025-1220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1220/
Summaries are generated and may contain mistakes; the official description above is the record.
