{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1226 exists.","fix":"No fix has been published for CVE-2025-1226 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-1226 is a medium-severity missing authorization vulnerability in ywoa, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1226 and fix it if it is affected.\n\nWhat it is: CVE-2025-1226 is a medium-severity missing authorization vulnerability in ywoa, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1226 exists.\n\nAffected product: ywoa. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1226/ (Markdown: https://insights.sbomify.com/CVE-2025-1226/index.md)","id":"CVE-2025-1226","markdown":"https://insights.sbomify.com/CVE-2025-1226/index.md","name":"CVE-2025-1226","record":{"aliases":["GHSA-9vcr-v878-4x73"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"ywoa OA system","requires_auth":"none","summary":"Remote attackers can bypass authorization in the setup interface to perform unauthorized actions, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"yimioa","vendor":"r1bbit"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability was found in ywoa up to 2024.07.03. It has been declared as critical. This vulnerability affects unknown code of the file /oa/setup/setup.jsp. The manipulation leads to improper authorization. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2024.07.04 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"ywoa setup.jsp improper authorization","id":"CVE-2025-1226","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"ywoa AddressDao.xml selectList sql injection","id":"CVE-2025-1227"},"packages":[],"prev":{"headline":"ywoa WXCallBack Interface XMLParse.java extract xml external entity reference","id":"CVE-2025-1225"},"products":["ywoa"],"published":"2025-02-12","related":[{"cvss_score":7.3,"headline":"Missing authorization in n/a","id":"CVE-2025-25585","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":6.1,"headline":"SQL injection in n/a","id":"CVE-2025-25580","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":6.1,"headline":"SQL injection in n/a","id":"CVE-2025-25582","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":6.1,"headline":"SQL injection in n/a","id":"CVE-2025-25590","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":5.3,"headline":"ywoa OaNoticeMapper.xml selectNoticeList sql injection","id":"CVE-2025-1216","kev_date_added":null,"published":"2025-02-12"},{"cvss_score":5.3,"headline":"ywoa UserMapper.xml listNameBySql sql injection","id":"CVE-2025-1224","kev_date_added":null,"published":"2025-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["n/a"]},"summary":"Remote attackers can bypass authorization in the setup interface to perform unauthorized actions, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-1226/"}