# CVE-2025-1226: ywoa setup.jsp improper authorization

> Remote attackers can bypass authorization in the setup interface to perform unauthorized actions, requiring an upgrade to the latest version.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-9vcr-v878-4x73

## What is CVE-2025-1226?

CVE-2025-1226 is a medium-severity missing authorization vulnerability in ywoa, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in ywoa up to 2024.07.03. It has been declared as critical. This vulnerability affects unknown code of the file /oa/setup/setup.jsp. The manipulation leads to improper authorization. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2024.07.04 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-1226?

It affects 1 product.


Products: R1bbit Yimioa.

## How do I fix CVE-2025-1226?

No fix has been published for CVE-2025-1226 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-1226 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1226 exists.

## Other vulnerabilities in ywoa

- [CVE-2025-25585](https://insights.sbomify.com/CVE-2025-25585/): Missing authorization in n/a (high 7.3)
- [CVE-2025-25580](https://insights.sbomify.com/CVE-2025-25580/): SQL injection in n/a (medium 6.1)
- [CVE-2025-25582](https://insights.sbomify.com/CVE-2025-25582/): SQL injection in n/a (medium 6.1)
- [CVE-2025-25590](https://insights.sbomify.com/CVE-2025-25590/): SQL injection in n/a (medium 6.1)
- [CVE-2025-1216](https://insights.sbomify.com/CVE-2025-1216/): ywoa OaNoticeMapper.xml selectNoticeList sql injection (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1226 and fix it if it is affected.

What it is: CVE-2025-1226 is a medium-severity missing authorization vulnerability in ywoa, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1226 exists.

Affected product: ywoa. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1226/ (Markdown: https://insights.sbomify.com/CVE-2025-1226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1226
- OSV: https://osv.dev/vulnerability/CVE-2025-1226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1226/
Summaries are generated and may contain mistakes; the official description above is the record.
