# CVE-2025-12419: Account takeover on OAuth/OpenID-enabled servers

> An authenticated attacker can take over user accounts by manipulating OAuth state tokens in Mattermost servers with specific SSO configurations.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-3x39-62h4-f8j6, GO-2025-4168

## What is CVE-2025-12419?

CVE-2025-12419 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 27 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12, 11.0.x <= 11.0.3 fail to properly validate OAuth state tokens during OpenID Connect authentication which allows an authenticated attacker with team creation privileges to take over a user account via manipulation of authentication data during the OAuth completion flow. This requires email verification to be disabled (default: disabled), OAuth/OpenID Connect to be enabled, and the attacker to control two users in the SSO system with one of them never having logged into Mattermost.

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2025-12419?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.4 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251028000919-d3ed703dc833 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251028000919-d3ed703dc833 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251028000919-d3ed703dc833 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-12419?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.5, 10.12.2, 10.5.13 or 11.0.4.

## Is CVE-2025-12419 being exploited?

There is no known exploitation of CVE-2025-12419 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)
- [CVE-2016-11074](https://insights.sbomify.com/CVE-2016-11074/): Mattermost Server: Insufficient Password-Reset Link Invalidation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12419 and fix it if it is affected.

What it is: CVE-2025-12419 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 27 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12419 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.4
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.4
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20251028000919-d3ed703dc833

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12419/ (Markdown: https://insights.sbomify.com/CVE-2025-12419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12419
- OSV: https://osv.dev/vulnerability/CVE-2025-12419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12419/
Summaries are generated and may contain mistakes; the official description above is the record.
