# CVE-2025-12421: Account Takeover via Code Exchange Endpoint

> Authenticated users can take over other accounts via the code exchange endpoint due to insufficient token verification in Mattermost.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-mp6x-97xj-9x62, GO-2025-4170

## What is CVE-2025-12421?

CVE-2025-12421 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 27 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2025-12421?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.13 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.3 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.3 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251022210333-acda1fb5dd46 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251022210333-acda1fb5dd46 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251022210333-acda1fb5dd46 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-12421?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.5, 10.12.2, 10.5.13 or 11.0.3.

## Is CVE-2025-12421 being exploited?

There is no known exploitation of CVE-2025-12421 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)
- [CVE-2016-11074](https://insights.sbomify.com/CVE-2016-11074/): Mattermost Server: Insufficient Password-Reset Link Invalidation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12421 and fix it if it is affected.

What it is: CVE-2025-12421 is a critical authentication bypass vulnerability in Mattermost Mattermost Server, published on 27 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12421 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.5
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.13
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.3
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.3
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20251022210333-acda1fb5dd46

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12421/ (Markdown: https://insights.sbomify.com/CVE-2025-12421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12421
- OSV: https://osv.dev/vulnerability/CVE-2025-12421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12421/
Summaries are generated and may contain mistakes; the official description above is the record.
