{"answers":{"affected":"2 open source packages ship an affected version, including drupal/simple_oauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12466 in the wild and no public exploit code.","fix":"Upgrade drupal/simple_oauth to 6.0.7 or later.","what":"CVE-2025-12466 is a high-severity authentication bypass vulnerability in Drupal Simple OAuth (OAuth2) \u0026 OpenID Connect, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12466 and fix it if it is affected.\n\nWhat it is: CVE-2025-12466 is a high-severity authentication bypass vulnerability in Drupal Simple OAuth (OAuth2) \u0026 OpenID Connect, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12466 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/simple_oauth (Packagist): affected from 6.0.0; fixed in 6.0.7\n- drupal/simple_oauth (Packagist): affected from 6.0.0; fixed in 6.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12466/ (Markdown: https://insights.sbomify.com/CVE-2025-12466/index.md)","id":"CVE-2025-12466","markdown":"https://insights.sbomify.com/CVE-2025-12466/index.md","name":"CVE-2025-12466","record":{"aliases":["DRUPAL-CONTRIB-2025-114","GHSA-jqmq-fpwv-p925"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal OAuth module","requires_auth":"none","summary":"Attackers can bypass authentication in the Drupal Simple OAuth module, gaining unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"simple_oauth","vendor":"simple_oauth_project"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Simple OAuth (OAuth2) \u0026 OpenID Connect allows Authentication Bypass.This issue affects Simple OAuth (OAuth2) \u0026 OpenID Connect: from 6.0.0 before 6.0.7.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Simple OAuth (OAuth2) \u0026 OpenID Connect - Critical - Access bypass - SA-CONTRIB-2025-114","id":"CVE-2025-12466","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Information disclosure in FunnelKit Automations – Email Marketing Automation and CRM for WordPress \u0026 WooCommerce","id":"CVE-2025-12468"},"packages":[{"ecosystem":"Packagist","fixed":["6.0.7"],"introduced":["6.0.0"],"last_affected":[],"package":"drupal/simple_oauth","purl":null,"source":"GHSA-jqmq-fpwv-p925"},{"ecosystem":"Packagist","fixed":["6.0.7"],"introduced":["6.0.0"],"last_affected":[],"package":"drupal/simple_oauth","purl":"pkg:composer/drupal/simple_oauth","source":"GHSA-jqmq-fpwv-p925"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["6.0.7"],"introduced":["6.0.0"],"last_affected":[],"package":"drupal/simple_oauth","purl":"pkg:composer/drupal/simple_oauth?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-114"}],"prev":{"headline":"Blind SQL Injection in QuickCMS","id":"CVE-2025-12465"},"products":["Simple OAuth (OAuth2) \u0026 OpenID Connect"],"published":"2025-10-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"Attackers can bypass authentication in the Drupal Simple OAuth module, gaining unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2025-12466/"}