# CVE-2025-12466: Simple OAuth (OAuth2) & OpenID Connect - Critical - Access bypass - SA-CONTRIB-2025-114

> Attackers can bypass authentication in the Drupal Simple OAuth module, gaining unauthorized access to protected resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-114, GHSA-jqmq-fpwv-p925

## What is CVE-2025-12466?

CVE-2025-12466 is a high-severity authentication bypass vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass.This issue affects Simple OAuth (OAuth2) & OpenID Connect: from 6.0.0 before 6.0.7.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-12466?

2 open source packages ship an affected version, including drupal/simple_oauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/simple_oauth` | Packagist | From 6.0.0 | 6.0.7 |
| `drupal/simple_oauth` | Packagist | From 6.0.0 | 6.0.7 |
| `drupal/simple_oauth` | Packagist:https://packages.drupal.org/8 | From 6.0.0 | 6.0.7 |

Products: Simple Oauth Project Simple Oauth.

## How do I fix CVE-2025-12466?

Upgrade drupal/simple_oauth to 6.0.7 or later.

## Is CVE-2025-12466 being exploited?

There is no known exploitation of CVE-2025-12466 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12466 and fix it if it is affected.

What it is: CVE-2025-12466 is a high-severity authentication bypass vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12466 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/simple_oauth (Packagist): affected from 6.0.0; fixed in 6.0.7
- drupal/simple_oauth (Packagist): affected from 6.0.0; fixed in 6.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12466/ (Markdown: https://insights.sbomify.com/CVE-2025-12466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12466
- OSV: https://osv.dev/vulnerability/CVE-2025-12466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12466/
Summaries are generated and may contain mistakes; the official description above is the record.
