CVE-2025-12499 Rich Shortcodes for Google Reviews <= 6.8 - Unauthenticated Stored Cross-Site Scripting via Google Review

High 7.2 Published Updated

Unauthenticated attackers can inject arbitrary web scripts via Google Review content, leading to stored XSS execution on user pages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-12499?

CVE-2025-12499 is a high-severity cross-site scripting vulnerability in widgetpack Rich Showcase for Google Reviews, published on 6 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.

Weakness: CWE-79

Which versions are affected by CVE-2025-12499?

How do I fix CVE-2025-12499?

No fix has been published for CVE-2025-12499 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-12499 being exploited?

There is no known exploitation of CVE-2025-12499 in the wild and no public exploit code.

Sources

Also known as GHSA-cjfp-rjvp-xqgj.

Is CVE-2025-12499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free