CVE-2025-1250 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can stall background job processing in GitLab by sending specially crafted commit messages, merge request descriptions, or notes.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-1250?

CVE-2025-1250 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.0 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed an authenticated user to stall background job processing by sending specially crafted commit messages, merge request descriptions, or notes.

Weakness: CWE-770

Which versions are affected by CVE-2025-1250?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.0.018.1.6, 18.2.6, 18.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-1250?

Upgrade gitlab to a fixed version for your release line: 18.1.6, 18.2.6 or 18.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-1250 being exploited?

There is no known exploitation of CVE-2025-1250 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-1250, GHSA-mmm6-54w9-rfq2.

Is CVE-2025-1250 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free