CVE-2025-12555 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Authenticated users can access previous pipeline job information on projects with disabled repository and CI/CD features due to improper authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12555?

CVE-2025-12555 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.1 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that, under certain conditions, could have allowed an authenticated user to access previous pipeline job information on projects with repository and CI/CD disabled due to improper authorization checks.

Weakness: CWE-863

Which versions are affected by CVE-2025-12555?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.1.018.7.6, 18.8.6, 18.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-12555?

Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-12555 being exploited?

There is no known exploitation of CVE-2025-12555 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12555, GHSA-w927-ccxx-qvrj, UBUNTU-CVE-2025-12555.

Is CVE-2025-12555 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free