CVE-2025-12559 Information Disclosure in Common Teams API
Authenticated users can view team email addresses intended for admins only via the common teams API endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-12559?
CVE-2025-12559 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 27 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to sanitize team email addresses to be visible only to Team Admins, which allows any authenticated user to view team email addresses via the GET /api/v4/channels/{channel_id}/common_teams endpoint
Weakness: CWE-200
Which versions are affected by CVE-2025-12559?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | None |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.5 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.5 |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.2 |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.13 |
8 more packages
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.13 |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.3 |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.3 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251015091448-abbf01b9db45 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251015091448-abbf01b9db45 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251015091448-abbf01b9db45 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-12559?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.5, 10.12.2, 10.5.13 or 11.0.3.
Is CVE-2025-12559 being exploited?
There is no known exploitation of CVE-2025-12559 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-4g87-9x45-cx2h, GO-2025-4169.