# CVE-2025-12571: Allocation of Resources Without Limits or Throttling in GitLab

> Unauthenticated attackers can cause a Denial of Service in GitLab by sending malicious JSON payloads, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 10 Dec 2025
- **Also known as:** BIT-gitlab-2025-12571, GHSA-3cq3-cj5m-hm72

## What is CVE-2025-12571?

CVE-2025-12571 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.10 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that could have allowed an unauthenticated user to cause a Denial of Service condition by sending specifically crafted requests containing malicious JSON payloads.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-12571?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 17.10.0 | 18.4.5, 18.5.3, 18.6.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-12571?

Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.

## Is CVE-2025-12571 being exploited?

There is no known exploitation of CVE-2025-12571 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12571 and fix it if it is affected.

What it is: CVE-2025-12571 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12571 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 17.10.0; fixed in 18.4.5, 18.5.3, 18.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12571/ (Markdown: https://insights.sbomify.com/CVE-2025-12571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12571
- OSV: https://osv.dev/vulnerability/CVE-2025-12571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12571/
Summaries are generated and may contain mistakes; the official description above is the record.
