{"answers":{"affected":"2 open source packages ship an affected version, including cloudinary.","exploited":"There is no known exploitation of CVE-2025-12613 in the wild and no public exploit code.","fix":"Upgrade cloudinary to 2.7.0 or later.","what":"CVE-2025-12613 is a high-severity vulnerability in cloudinary, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12613 and fix it if it is affected.\n\nWhat it is: CVE-2025-12613 is a high-severity vulnerability in cloudinary, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12613 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cloudinary (npm): affected all versions; fixed in 2.7.0\n- cloudinary (npm): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12613/ (Markdown: https://insights.sbomify.com/CVE-2025-12613/index.md)","id":"CVE-2025-12613","markdown":"https://insights.sbomify.com/CVE-2025-12613/index.md","name":"CVE-2025-12613","record":{"aliases":["CLSA-2026-1787310891","GHSA-g4mf-96x5-5m2c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudinary npm package","requires_auth":"none","summary":"Attackers can inject unintended parameters via ampersands in Cloudinary library inputs, potentially bypassing security checks or altering data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Versions of the package cloudinary before 2.7.0 are vulnerable to Arbitrary Argument Injection due to improper parsing of parameter values containing an ampersand. An attacker can inject additional, unintended parameters. This could lead to a variety of malicious outcomes, such as bypassing security checks, altering data, or manipulating the application's behavior.\r\r**Note:**\rFollowing our established security policy, we attempted to contact the maintainer regarding this vulnerability, but haven't received a response.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloudinary Node SDK is vulnerable to Arbitrary Argument Injection through parameters that include an ampersand","id":"CVE-2025-12613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"SourceCodester Best House Rental Management System admin_class.php delete_payment sql injection","id":"CVE-2025-12614"},"packages":[{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"cloudinary","purl":null,"source":"GHSA-g4mf-96x5-5m2c"},{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"cloudinary","purl":"pkg:npm/cloudinary","source":"GHSA-g4mf-96x5-5m2c"}],"prev":{"headline":"Campcodes School Fees Payment Management System ajax.php sql injection","id":"CVE-2025-12612"},"products":["cloudinary"],"published":"2025-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-15","vendors":["n/a"]},"summary":"Attackers can inject unintended parameters via ampersands in Cloudinary library inputs, potentially bypassing security checks or altering data.","url":"https://insights.sbomify.com/CVE-2025-12613/"}