# CVE-2025-12613: Cloudinary Node SDK is vulnerable to Arbitrary Argument Injection through parameters that include an ampersand

> Attackers can inject unintended parameters via ampersands in Cloudinary library inputs, potentially bypassing security checks or altering data.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 15 Aug 2026
- **Also known as:** CLSA-2026-1787310891, GHSA-g4mf-96x5-5m2c

## What is CVE-2025-12613?

CVE-2025-12613 is a high-severity vulnerability in cloudinary, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package cloudinary before 2.7.0 are vulnerable to Arbitrary Argument Injection due to improper parsing of parameter values containing an ampersand. An attacker can inject additional, unintended parameters. This could lead to a variety of malicious outcomes, such as bypassing security checks, altering data, or manipulating the application's behavior.**Note:**Following our established security policy, we attempted to contact the maintainer regarding this vulnerability, but haven't received a response.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2025-12613?

2 open source packages ship an affected version, including cloudinary.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cloudinary` | npm | All versions | 2.7.0 |
| `cloudinary` | npm | All versions | 2.7.0 |

## How do I fix CVE-2025-12613?

Upgrade cloudinary to 2.7.0 or later.

## Is CVE-2025-12613 being exploited?

There is no known exploitation of CVE-2025-12613 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12613 and fix it if it is affected.

What it is: CVE-2025-12613 is a high-severity vulnerability in cloudinary, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12613 in the wild and no public exploit code.

Affected packages and fixed versions:
- cloudinary (npm): affected all versions; fixed in 2.7.0
- cloudinary (npm): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12613/ (Markdown: https://insights.sbomify.com/CVE-2025-12613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12613
- OSV: https://osv.dev/vulnerability/CVE-2025-12613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12613/
Summaries are generated and may contain mistakes; the official description above is the record.
