CVE-2025-12653 Authentication Bypass by Spoofing in GitLab

Medium 6.5 Published Updated

Unauthenticated attackers can join arbitrary organizations by spoofing headers, potentially gaining unauthorized access to private data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12653?

CVE-2025-12653 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.3 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that under specific conditions could have allowed an unauthenticated user to join arbitrary organizations by changing headers on some requests.

Weakness: CWE-290

Which versions are affected by CVE-2025-12653?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.3.018.4.5, 18.5.3, 18.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-12653?

Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-12653 being exploited?

There is no known exploitation of CVE-2025-12653 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12653, GHSA-2v4g-65gf-w58f.

Is CVE-2025-12653 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free