CVE-2025-12697 Improper Encoding or Escaping of Output in GitLab
Authenticated maintainers can reveal Datadog API credentials due to improper output encoding in GitLab.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-12697?
CVE-2025-12697 is a low-severity vulnerability in Gitlab Gitlab, published on 11 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.5 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user with maintainer-role permissions to reveal Datadog API credentials under certain conditions.
Weakness: CWE-116
Which versions are affected by CVE-2025-12697?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.5.0 | 18.7.6, 18.8.6, 18.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-12697?
Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.
Is CVE-2025-12697 being exploited?
There is no known exploitation of CVE-2025-12697 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-12697, GHSA-jqw6-r3pp-rfvr, UBUNTU-CVE-2025-12697.