CVE-2025-12704 Missing Authorization in GitLab

Low 3.5 Published Updated

Authenticated users can access Virtual Registry data in groups they do not belong to due to improper authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-12704?

CVE-2025-12704 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.2 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user to access Virtual Registry data in groups where they are not members due to improper authorization under certain conditions.

Weakness: CWE-862

Which versions are affected by CVE-2025-12704?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.018.7.6, 18.8.6, 18.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-12704?

Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-12704 being exploited?

There is no known exploitation of CVE-2025-12704 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12704, GHSA-5prc-f4c3-qjpv.

Is CVE-2025-12704 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free