{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-12705 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-12705 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-12705 is a high-severity cross-site scripting vulnerability in widgetpack Reviews Widgets for Google, Yelp \u0026 TripAdvisor, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12705 and fix it if it is affected.\n\nWhat it is: CVE-2025-12705 is a high-severity cross-site scripting vulnerability in widgetpack Reviews Widgets for Google, Yelp \u0026 TripAdvisor, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12705 in the wild and no public exploit code.\n\nAffected product: widgetpack Reviews Widgets for Google, Yelp \u0026 TripAdvisor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12705/ (Markdown: https://insights.sbomify.com/CVE-2025-12705/index.md)","id":"CVE-2025-12705","markdown":"https://insights.sbomify.com/CVE-2025-12705/index.md","name":"CVE-2025-12705","record":{"aliases":["GHSA-cp8c-5fqx-2h88"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary web scripts via social media reviews, leading to stored XSS execution on user pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Social Reviews \u0026 Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Social Reviews \u0026 Recommendations \u003c= 2.5 - Unauthenticated Stored Cross-Site Scripting via Social Media Reviews","id":"CVE-2025-12705","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":6,"next":{"headline":"Library Management System \u003c= 3.2.1 - Unauthenticated SQL Injection","id":"CVE-2025-12707"},"packages":[],"prev":{"headline":"Missing Authorization in GitLab","id":"CVE-2025-12704"},"products":["Reviews Widgets for Google, Yelp \u0026 TripAdvisor"],"published":"2025-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["widgetpack"]},"summary":"Unauthenticated attackers can inject arbitrary web scripts via social media reviews, leading to stored XSS execution on user pages.","url":"https://insights.sbomify.com/CVE-2025-12705/"}