CVE-2025-12716 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An authenticated user can execute cross-site scripting attacks via malicious wiki pages to perform unauthorized actions on behalf of other users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-12716?

CVE-2025-12716 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.4 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that, under certain conditions could have allowed an authenticated user to perform unauthorized actions on behalf of another user by creating wiki pages with malicious content.

Weakness: CWE-79

Which versions are affected by CVE-2025-12716?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.4.018.4.6, 18.5.4, 18.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-12716?

Upgrade gitlab to a fixed version for your release line: 18.4.6, 18.5.4 or 18.6.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-12716 being exploited?

There is no known exploitation of CVE-2025-12716 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12716, GHSA-6v2x-53rq-w964.

Is CVE-2025-12716 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free