# CVE-2025-12738: Enumeration of restricted property value

> An attacker with limited database access can infer restricted property values by observing error messages during SET operations, leading to information disclosure.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U/V:D`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-qcj4-rf2h-2w2x

## What is CVE-2025-12738?

CVE-2025-12738 is a low-severity vulnerability in neo4j Enterprise Edition, published on 22 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Neo4j Enterprise edition versions prior to 2025.11.2 and 5.26.17 are vulnerable to a potential information disclosure by an attacker who has some legitimate access to the database. The vulnerability allows attacker without read access to a property to infer information about its value by trying to enumerate all possible values through observing error messages of SET property.
We recommend upgrading to 2025.11.2 or 5.26.17 and above, where the issues is fixed.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-12738?


## How do I fix CVE-2025-12738?

No fix has been published for CVE-2025-12738 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-12738 being exploited?

There is no known exploitation of CVE-2025-12738 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12738 and fix it if it is affected.

What it is: CVE-2025-12738 is a low-severity vulnerability in neo4j Enterprise Edition, published on 22 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12738 in the wild and no public exploit code.

Affected product: neo4j Enterprise Edition. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12738/ (Markdown: https://insights.sbomify.com/CVE-2025-12738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12738
- OSV: https://osv.dev/vulnerability/CVE-2025-12738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12738/
Summaries are generated and may contain mistakes; the official description above is the record.
