# CVE-2025-12760: Email TFA - Moderately critical - Access bypass - SA-CONTRIB-2025-115

> Attackers can bypass two-factor authentication in Drupal Email TFA, allowing unauthorized access to user accounts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 18 Nov 2025
- **Also known as:** DRUPAL-CONTRIB-2025-115, GHSA-9jrw-jrrj-p6fr

## What is CVE-2025-12760?

CVE-2025-12760 is a medium-severity authentication bypass vulnerability in Drupal Email TFA, published on 18 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Email TFA allows Functionality Bypass.This issue affects Email TFA: from 0.0.0 before 2.0.6.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-12760?

2 open source packages ship an affected version, including drupal/email_tfa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/email_tfa` | Packagist | All versions | 2.0.6 |
| `drupal/email_tfa` | Packagist | All versions | 2.0.6 |
| `drupal/email_tfa` | Packagist:https://packages.drupal.org/8 | All versions | 2.0.6 |

Products: Email Tfa Project Email Tfa.

## How do I fix CVE-2025-12760?

Upgrade drupal/email_tfa to 2.0.6 or later.

## Is CVE-2025-12760 being exploited?

There is no known exploitation of CVE-2025-12760 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Email TFA

- [CVE-2025-31676](https://insights.sbomify.com/CVE-2025-31676/): Email TFA - Moderately critical - Access bypass - SA-CONTRIB-2025-001 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12760 and fix it if it is affected.

What it is: CVE-2025-12760 is a medium-severity authentication bypass vulnerability in Drupal Email TFA, published on 18 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12760 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/email_tfa (Packagist): affected all versions; fixed in 2.0.6
- drupal/email_tfa (Packagist): affected all versions; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12760/ (Markdown: https://insights.sbomify.com/CVE-2025-12760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12760
- OSV: https://osv.dev/vulnerability/CVE-2025-12760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12760/
Summaries are generated and may contain mistakes; the official description above is the record.
